I ran into a situation where I was trying out WS-Discovery.

you know the new WCF capability that allows you dynamically find services on your local network.

Which would come in handy if say some company created software that ran on windows and hosted some services that could automatically link up with co-workers clients like windows phone and maybe even the plasma screen or microsoft surface computer?

 

Well i ran into a little hiccup today where enabling the virtual network interface for Hyper-V on my laptop caused discovery to throw an exception...

 

I ran the DiscoveryChat solution from the .NET40 training kit february drop

(the "end" solution at
C:\VS2010TrainingKit\Labs\WhatsNewInWCF4\Source\Ex4-ServiceDiscovery\End\C#)


and in the OnFindCompleted method

( the method that asynchronously returns with the discovery client is done )

FindCompletedEventArgs.Error returned an exception

 

here are the details...

-----------------------------------------

FindCompletedEventArgs.Error is not null.

[System.ServiceModel.CommunicationException] = {"An unexpected socket exception occurred when sending data.  See inner exception for details."}

InnerException = {"A socket operation was attempted to an unreachable host"}

StackTrace = "\r\nServer stack trace: \r\n   at System.Runtime.AsyncResult.End[TAsyncResult](IAsyncResult result)\r\n   at System.ServiceModel.Channels.ServiceChannel.SendAsyncResult.End(SendAsyncResult result)\r\n   at System.ServiceModel.Channels.ServiceChannel.EndCal...

source mscorlib.

 

next steps

------------------------------------------------


after bumbling around in different places i started playing with my network interfaces...
I have three network interfaces in my Control Panel\Network and Internet\Network Connections

1. Local Area Connection (Broadcom NetLink (TM) Gigabit Ethernet)

2. Local Area Connection - Virtual Network (probably from Hyper-V)

3. Wireless Network Connection (Intel(R) WiFi Link 5300 AGN)

i disabled 2 and 3 and discovery worked

i re-enabled and reproduced the error

i enabled everything then disabled Virtual Network and.. ooo nooo .. it worked!

I then disabled the Virtual Network and it didnt work :(

Just to make sure I turned on one of the Hyper-V servers and browsed a website from inside the VM pinged it pinged from the VM to my host and to other machines on the network finally i enabled everything then disabled Virtual Network it worked!

I then disabled the Virtual Network and it didnt work :(

 

Views: 104

Replies to This Discussion

ok seems to be fine now.

at some point It statred to work and then a reboot brought the problem back.
I removed the network interface from the virtual network manager and created a new one with all the defaults.

that seemed to have fixed the problem even after a reboot.

maybe it was some flaky underlying configuration for that particular virtual interface? i dunno.

RSS

Latest Activity

Anthony.Tex.M posted a status
"We are ACTIVE on http://www.hccug.org ... and open for new members!"
Feb 21
Profile IconRobert Tang, SharepointKing, george and 10 more joined Azure User Groups
Mar 20, 2009
SharepointKing posted a discussion

What is new in Azure for SharePoint

I like to know what is new in Azure for Sharepoint that can make life easier for Developer.
Mar 20, 2009
Profile IconRon Brayer and Giuseppe Turitto are attending David Pallmann's event

Next Azure Meeting of the NYC Cloud Computing Group 3/23/2009 at Microsoft

March 23, 2009 from 6pm to 8pm
The NYC Azure Cloud Computing Group meets again March 23, 2009Microsoft, 1290 Avenue of the Americas, 6th floor, NYC, NY6:00 - 8:00 pmhttp://cl.exct.net/?qs=3536b166bb2eed3245895f36cc7d0c58445e8854810d08588fa0a8ec86f09b9aBE SURE TO REGISTER...Space fills up fast andBuilding Security Requires it.This month...Chris Rolon, Architectural Consultant Neudesic LLC will be presenting on...Live Services and Live IDIn this month's meeting, we will be learning about how Live ID integration works in the…See More
Mar 20, 2009

© 2017   Created by Azure Admin.   Powered by

Badges  |  Report an Issue  |  Terms of Service